WordPress und der verflixte weiße Bildschirm – vielleicht hier eine Lösung

Der ein oder andere Besucher wird heute hier aufschlagen, weil mein altes und sehr populäres Post „Technorati ist tot, lange lebe Wikio“ sich plötzlich kommentartechnisch selbstständig gemacht hat. Das ist so leider auch nicht ganz richtig, denn ich selbst bin für die erneute Versendung der alten Kommentare verantwortlich. Schuld daran ist die weiße Seite. Aber vielleicht von Anfang an.

I

m Februar vorletzten Jahres habe ich die Aktion „Wikiofreunde“ ins Leben gerufen. Dabei handelt es sich um eine Aktion für neue frische Blogs sich noch anders public zu machen als über Google und neuen Leser zu gewinnen. Das größter Problem für jeden neuen Blog ist es, und da spreche ich auch von mir, Leser zu finden. Aber in der doch mittlerweile sehr stark besiedelten Welt des Internets ist es schwierig auf sich aufmerksam zu machen.

Wikiofreunde

Aus dieser Frage heraus rief mein Namensvetter Matthias die Aktion „Technorati-Freunde“ ins Leben. Allerdings hat uns der amerikanische Service Technorati als nicht besonders hilfreich erwiesen und aus diesem Grund sind wir zu Wikio gewechselt.

D

ie Aktion wurde zum Erfolg, zumindestens ist das meine Sicht. Die meisten Teilnehmer haben mehr und regelmäßige Besucher und Kommentatoren bekommen. Und die Links wurden auch mehr und das war der Sinn, oder? Auf jeden Fall hat dieser Artikel mittlerweile mehr als 400 Kommentare und das scheint mein WordPress System nicht mehr mitzumachen. Denn einer unserer neusten Teilnehmer, Stefan, hat mich netterweise darauf hingewiesen, dass der Originalartikel nur noch als weiße Seite angezeigt wird. Danke dafür, Stefan!

Auf jeden Fall habe ich versucht die Last des Artikel für mein System zu schmälern, indem ich ein paar Kommentare rausnahm mit dem Button „Unapprove“. Auf jeden Fall habe ich die Kommentare rausgenommen, aber leider hat es nichts geholfen! Und als ich die Kommentare mit „Approve“ wieder reingeholt habe, hat das System automatisch wieder die Kommentare versandt. Sorry, dafür! Ich hoffe ich habe euch damit keine Unannehmlichkeiten gemacht.

A

ch so ihr wollt wissen, was geholfen hat? Ich habe einfach unter dem Punkt „Settings“ unter dem Punkt „Discussion“, „Other comment settings“ den Umbruch auf 200 Stück reduziert. Und jetzt funktioniert der Artikel wieder und ihr könnt wenn ihr wollt noch teilnehmen. Einfach über mein Kontaktformular Bescheid geben. Also los, einfach probieren, was habt ihr zu verlieren. Ach so, es wäre natürlich toll, wenn ihr im Gegenzug zur Teilnehme einfach das „Wikiofreunde“ – Widget von Tanja, bei euch auf der Seite installiert. Dann hat jeder was davon, oder? Und über Kommentare und Tweets würde ich mich freuen und somit würden noch mehr Leute darauf aufmerksam werden. Vielen Dank!

12 Kommentare Schreibe einen Kommentar

  1. Pingback: Mac

    • Hallo Marco,

      das soll der Vorführeffekt sein, um zu zeigen, wie es vorher ausgesehen hat.

      Aber ich werde versuchen auch hier das Problem zu beheben! ;-)

  2. Pingback: Stefan

  3. Hallo Matthias,

    freut mich, dass es wieder funktioniert! Genau den Tipp wollte ich Dir auch geben, aber ich habe heute erst Deine letzte Mail gelesen, sonst hätte ich Dir früher schon antworten können.

    Ich denke mal, es waren einfach zu viele Kommentare, die das PHP-Memory-Limit überfordert haben. Und wenn Du sagst, Du hast den Umbruch auf 200 reduziert, denke ich mal auch, dass das der Grund war, denn ich glaube in den Standardeinstellungen sind hier 50 Kommentare pro Seite eingestellt.

    Ist ja irgendwo auch nachvollziehbar, denn überleg mal, wie viel da pro Seite geparst werden muss von PHP, um die Seite zu erzeugen, wenn dort so viele Kommentare pro Seite vorhanden sind.

    Aber wichtig ist, es klappt wieder!

    Zu den Wikio-Freunden kann ich sagen, dass da eine super Idee war und auch bleiben wird! Ich habe seit Beginn meiner „Mitgliedschaft“ im April 2010 viele neue Blogs kennen gelernt, die ich mittlerweile regelmäßig besuche! Und ich hoffe, dass dieses Projekt auch noch viele weitere interessante Blogs zu Tage fördert! :-)

    • Hallo Stefan,

      nochmal an dieser Stelle vielen Dank für deinen Hinweis! Ich bin auf so etwas mittlerweile angewiesen, weil auch meine Seite teilweise mehr Aufmerksamkeit verlangt, als ich habe! ;-)

      Deshalb sind Leute wie du für mich wichtig, die mit offenen Augen durchs Leben gehen und mich bzw. andere auf Unregelmäßigkeiten hinweisen, danke dafür!

      Zu der Aktion, als ich sie startete war mir ehrlich nicht bewußt, was ich da lostrete und ich hoffe, dass noch viele Blogs teilnehmen werden. Ich hoffe einfach, dass wir es damit einmal schaffen, den sehr gut verlinkten amerikanischen Blogs Parolie zu bieten! Einfach eine bessere Verlinkung zu schaffen! Und ich glaube das funktioniert! ;-)

      Schönen Restsonntag und wir lesen uns

  4. Also das die Seite nicht angezeigt wurde ist sehr schlecht. Ich habe einen Artikel mit 1200 Kommentaren. Die lädt zwar etwas langsamer, aber es bleibt noch im Rahmen.
    Das aufteilen der Kommentare auf einzelnen Seiten mag zwar das Problem lösen, aber soweit ich weiß ist das SEO technisch absolut schlecht. Daher habe ich auch darauf verzichtet die Funktion einzuschalten. Dann lieber einen Artikel, der schlecht lädt, als alle Artikel SEO technisch versaut.
    Leider kann ich dir nicht mehr genau sagen, was jetzt der Grund ist und wo ich es gelesen hatte.
    Vielleicht könntest du den Artikel in einen zweiten aufteilen, wo es dann weiter geht?
    Viele Grüße
    Thomas

    • Hallo Thomas,
      Ich hatte den Artikel am Anfang nicht aufgeteilt, da funktionierte er.

      Daraus habe ich geschlossen, dass es vielleicht an einem der neueren Kommentare liegt und somit habe ich die dann „Unapproved“. Hat aber leider auch nichts genutzt.

      Deshalb werde ich diesen Artikel jetzt auch vorerst so mal lassen und mich später mal drum kümmern, das Ganze aufzuräumen!

      Aber danke, dass du mich mit deinen Erfahrungen unterstützt! Das sagt mir ich liege dann wirklich falsch mit meiner Vermutung!

      Aber eine Frage habe ich noch, du hast einen eigenen Server, oder? Denn ich habe das kleinste Packet bei All-Inkl, vielleicht liegt es dort doch an der Performance? Ich wollte sowiesso auf das nächst höhere mal wechseln, vielleicht erledigt sich ja dann das „Problem“? Mal schauen!

  5. @Matthias:
    Ich hab doch nur Bescheid gegeben, hätte (hoffe ich) jeder andere hier bestimmt auch gemacht, wenn er es gesehen hätte! ;-)

    @Thomas:
    Wegen der Seitennutzung bei den Kommentaren, hier ist meiner Meinung nach das Problem, dass im Standard-Code duplicate Content erzeugt wird. Hier gibt es aber Snippets, um das Problem zu lösen, sie z.B. dieser Artikel.

    Im Grunde genommen hat man die Wahl zwischen Pest oder Cholera. Entweder man nimmt in Kauf, SEO-technisch sich ein Ei ins Nest zu legen oder längere Ladezeiten in Kauf zu nehmen. Oder man erlaubt nur eine begrenzte Anzahl an Kommentaren! :-)

    Hier sind die noch nicht so bekannten Blogs im Vorteil, da diese auch noch nicht so viele Kommentare bekommen! :-D

    • Hallo Stefan,

      danke trotzdem! ;-) Und ja du hast Recht, Pest oder Cholera, das ist hier die Frage, aber wie ich in Thomas Kommentar bereits erläutert habe, ich möchte demnächst sowieso auf das größere Packet, dann könnte sich das Problem vielleicht schon erledigen? ;-)

    • Ja, das ist richtig, Marc. Ich habe hier im blog die Kommentare so angepasst, wie sie mir gefallen haben.

      Und dabei habe ich aus Versehen auch die Blätternfunktion gelöscht. Ich werde mich dieser Tage mal hinsetzen und selbige wieder einbauen. Dauert aber leider ein weinig!

      Darf ich dich in der Zwischenzeit einfach mal fragen, was du als sehr aktiver Teilnehmer der Wikiofreunde Aktion von Selbiger hälst? Hat sie dir was gebracht?

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.


This Blog will give regular Commentators DoFollow Status. Implemented from IT Blögg